WordPress 4.9以降の主なリリース一覧表

新バージョン

WordPress直近バージョン

WordPressは、積極的に保守されている5.3系統の最新版以外の以下のバージョンは、安全に使用することはできません。

Verリリース脆弱性とバージョン推移
WordPress 4.9以降の主なリリース
5.3.219/12/18メンテナンス リリース
5件の修正と改良
5.3.119/12/13セキュリティ+メンテナンス リリース
5.3 以前のバージョンに影響する4件のセキュリティ問題修正
 1.権限のないユーザーにREST API 経由での先頭固定投稿を許してしまう問題
 2.巧妙に手が加えられたリンクを用いたクロスサイトスクリプティング (XSS) 脆弱性の問題
 3.WordPress.org セキュリティチームによるwp_kses_bad_protocol()の強化。
 4.ブロックエディター本文を用いた格納型XSS 脆弱性
+ メンテナンス更新
5.319/11/13メジャーバージョン アップ
ブロックエディターを拡張、洗練させ、より直感的な操作感と改善されたアクセシビリティを実現
新しいデフォルトテーマ Twenty Twenty によって、デザインの柔軟性とブロックエディターとの統合が実現
5.2.519/12/13セキュリティ リリース・ 以前のバージョンに影響する4件のセキュリティ問題修正
5.2.419/10/15セキュリティ リリース
クロスサイトスクリプティング(XSS) 脆弱性対応を含む6件のセキュリティ問題を修正
5.2.319/09/05セキュリティ リリース
複数のクロスサイトスクリプティング(XSS) 脆弱性対応。オープンリダイレクトに繋がりうる URL のバリデーションとサニタイズの問題。  5.0とそれ以前のバージョンにもアップデートされたバージョンがあります。WordPress の古いバージョンの jQuery をアップデートしています。この変更は5.2.1で加えられたもので、今回、4.1ブランチまでの古いバージョンへも反映されました。(各リリースを参照)&メンテナンス リリース:29個のバグを修正
積極的に保守されている5.2系統の最新版以外の以下のバージョンは、安全に使用することはできません。
5.2.219/07/24メンテナンス リリース:13個のバグを修正
5.2.119/05/225.2.1は 5.2の機能の改善と33件のバグを修正しています。
5.219/05/19, 05/08メジャーバージョン:5.2ブランチ(5.2系統)
5.1.419/12/13セキュリティ リリース・ 以前のバージョンに影響する4件のセキュリティ問題修正
5.1.219/09/05セキュリティ リリース
複数のクロスサイトスクリプティング(XSS) 脆弱性対応。オープンリダイレクトに繋がりうる URL のバリデーションとサニタイズの問題。  WordPress の古いバージョンの jQuery をアップデートしています。この変更は5.2.1で加えられたもので、今回、古いバージョンへも反映されました。
5.1.119/05/11, 04/09コメントをフィルタ処理してデータベースに格納する方法を処理するための セキュリティ リリース : ホームページの存在を確認
5.119/03/11, 02/22メジャーバージョン:エディター全体のパフォーマンスの向上(5.1系統)
5.0.819/12/13セキュリティ リリース・ 以前のバージョンに影響する4件のセキュリティ問題修正
5.0.619/09/05セキュリティ リリース
複数のクロスサイトスクリプティング(XSS) 脆弱性対応。オープンリダイレクトに繋がりうる URL のバリデーションとサニタイズの問題。  WordPress の古いバージョンの jQuery をアップデートしています。この変更は5.2.1で加えられたもので、今回、古いバージョンへも反映されました。
5.0.419/04/09, 03/13コメントをフィルタ処理してデータベースに格納する方法を処理するためのセキュリティ リリース
5.0.319/03/1337個のバグ修正リリース : ホームページの存在を確認
5.0.219/01/0973個のバグに取り組むメンテナンス リリース
5.0.118/12/183.7以降のすべてのバージョンに対する セキュリティ リリース(XSS:クロスサイトスクリプティング、権限外の操作を行える、個人情報が漏れる可能性があるなどの 脆弱性に対応)
5.018/12/10メジャーバージョン( 下位(4.9ブランチや4.8ブランチ以前などのバージョンから)からの自動バージョンアップ無し):5.0ブランチ(5.0系統)
4.9.1319/12/13セキュリティ リリース・ 以前のバージョンに影響する3件のセキュリティ問題修正
4.9.1119/09/05セキュリティ リリース
複数のクロスサイトスクリプティング(XSS) 脆弱性対応。オープンリダイレクトに繋がりうる URL のバリデーションとサニタイズの問題。  WordPress の古いバージョンの jQuery をアップデートしています。この変更は5.2.1で加えられたもので、今回、古いバージョンへも反映されました。
4.9.1019/03/13コメントをフィルタ処理してデータベースに格納する方法を処理するための セキュリティ リリース : ホームページの存在を確認
4.917/11/17大規模なカスタマイザーの改善、コードエラーのチェック(4.9系統)

コメント

タイトルとURLをコピーしました